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Imagine this: You’re a creative person 

working in Adobe Photoshop CS2 and you come 

across a new feature called the Script Events 

Manager. Doesn’t sound very exciting, does it? 

And it’s likely a feature you haven’t explored 

much. Even though the name may sound scary, 

the Script Events Manager is actually one of the 

best-kept secrets in Photoshop CS2 when it comes 

to getting things done quickly and efficiently.

 We asked Marc Pawliger and Tom Ruark from 

Adobe Systems Inc. for their input on this new 

feature, so let’s see if we can help open the door 

to the secrets of the Script Events Manager.
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By Matt Kloskowski
Matt Kloskowski is an Education and Curriculum Developer for the NAPP and 
has authored or co-authored several books on Photoshop and Illustrator. He 
also teaches an advanced Photoshop course for www.sessions.edu.



What is an event?
When it comes to software and 

your computer, the word “event” is 
a techie term that programmers use to 

describe a message that your software sent 
to announce that something has happened. 

In Photoshop, think of an event as a signal 
telling Photoshop that something important just 

occurred. For example, when you click on a tool in 
the Toolbox, your computer signals Photoshop that a 

“Click” event has occurred. When you open a photo, an 
“Open” event occurs. 

As you can imagine, the list of events can go on for 
quite a while, but the most important point of this 
explanation is: The Script Events Manager “knows” 
when events occur, so you can tell it to do something 
when the event happens. 

Not just for scripts
One essential message that we want to convey is 

that the Script Events Manager isn’t just for those 
programming-code-savvy people who know 

how to write and use scripts. If you can create 
an action in Photoshop, then you can use 
(and I mean really take advantage of ) the 
Script Events Manager—it’s that simple. 

 In fact, I encourage you to take the word “Script” out of this 
tool’s name. Just think of it as an “Events Manager.” Now that you 
know what an event is, think about all the things that happen in 
Photoshop for which you wish you could automatically run an 
action. Well, instead of manually running an action (or script), 
you can let the Script Events Manager do it for you based on 
events that occur when you’re working on your digital images. 

Getting started
The good news is that you don’t need to install or configure 
anything to use the Script Events manager. Everything you need 
is right in front of you in Photoshop CS2. 
 In this example, we’ll add some file information (metadata)  
to any documents that we create in Photoshop so that we 
always have our copyright and contact info in our images. 
To do this, let’s create a new action by clicking on the Create 
a New Action icon at the bottom of the Actions palette 
(Window>Actions), record a step that chooses File>File Info,  
add contact and copyright information, then click OK to close 
the dialog. Press Stop recording to stop the action and  
your action is ready to use. Now let’s move on to the nuts  
and bolts of the Script Events Manager. 
[NAPP members may download this sample action, an action  
for centering guides, and one for the “rule of thirds” from www 
.photoshopuser.com/members/magcenter/2006.php.] 

When Photoshop CS2 was introduced, a new feature went largely 
unnoticed: the Script Events Manager. It didn’t get much exposure 
but as more and more people acquired this new version of Photo-
shop, questions began coming in about this new feature in the 
File>Scripts menu (see “Q&A” on page 39). As people began digging 
around to find out what it did, we began hearing and reading a 
lot of, “Wow…, this Script Events thing is sweet!” And rightly so, 
because the Script Events Manager gives us a revolutionary new 
way to automate things in Photoshop. If you like using actions and 
scripts, then you’re going to absolutely love this new tool. And if 
you don’t, then read this article anyway to see what the Script 
Events Manager can do to save you time. You’ll 
soon be creating more actions (and if 
you’re brave, maybe scripts too) 
just to take advantage 
of this feature.
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Insert copyright in entire photo library—move ahead  5 spaces
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Overwrite Images 
Folder—go back 5 spaces

As Director of Product Engineering  at Adobe, Marc Pawliger is responsible for the  engineering, testing, and ultimately the delivery  of each version of Photoshop. He has been at Adobe for 11 years, working on and around Photoshop  the entire time. 

Photoshop User asked Adobe’s Marc Pawliger,  about the history and special features of the  Script Events Manager. 

Photoshop User: How did the idea for Script Events come about? What was the motivation to turn them into a feature in CS2?

Marc Pawliger: We get a ton of user requests for customization, for example, “When I open a file,  I want Photoshop to automatically zoom to fill the screen,” or, “When I save a document, I want to automatically make a backup copy of the previous version.” We had a hard time figuring out how a user would configure all these various customiza-tions. Where would that go in Preferences while still remaining usable? It was a common question we couldn’t answer in a general enough way to be useful for the many ways users wanted to use the capability. The first attempt at an answer was the addition of actions in Photoshop 4.0 and it has taken a long time to get our users to create their own actions. But since actions have to be run manually, it still doesn’t answer those requests. Users want these things to happen automatically.
 Photoshop 5.0 added the ability for software developers to write plug-ins to run commands  automatically, but that was still too complex a  solution for most users, as the learning curve for writing a plug-in is very high.

 Then Photoshop CS made things a little easier by enabling scripts—small programs written in the JavaScript scripting language—to run commands. Writing JavaScript is much easier to learn than 

creating a plug-in, so we started to see more users creating scripts. But again, this was still a manual solution. We still needed a way for users to connect the pieces together. 
 Finally, Photoshop CS2 allows easy access via the File>Scripts>Script Events Manager dialog for a user to trigger a script or action based on some type of event that occurs in Photoshop.

PSU: If the Script Events Manager isn’t just for programmers, can you tell us about its wide  range of use?

MP: We’re always amazed with what users can do with Photoshop. We’ll put in a feature like Script Events and users will come up with amazingly creative ways to use the feature to do things we just couldn’t imagine when we added it. Users can create actions or scripts that do just what you would have to do manually via menu commands, and they can run automatically.

PSU: How can our readers (Photoshop users) extend the Script Events Manager to customize it for their specific needs?

MP: You can do this in two ways: The first is to create an action or write a script and use the Script Events Manager to run the script when, say, you print or open a file.
 If the available trigger events aren’t enough, you can add more events that are triggered when you run another script. You need only write a script to create these new events. If you have Photoshop CS2 installed, you already have some examples to start with. You can find them in Applications:Adobe Photoshop CS2:Presets:Scripts:Event Scripts Only (PC: Program Files\Adobe Photoshop CS2\Presets\Scripts\Event Scripts Only). Then you tie the event  to the script you write via the Script Events Manager, and you’re on your way.

An Interview with Marc Pawliger



The first thing to 
do is open the Script 

Events Manager dialog by 
choosing File>Scripts>Script Events 

Manager and the most important thing 
to remember when you open this window 

is to click the Enable Events to Run Scripts/
Actions checkbox. Now we’re ready to start 

doing the cool stuff. 

Under Photoshop Event, choose New Document from 
the drop-down menu. (This is one of those “events” that we 

talked about earlier.) Every time you create a new docu-
ment, a notification is sent to Photoshop and we can 

intercept it to perform some step, such as running the 
action we just created. So, we’ll select the Action 

option and choose the File Info (copyright) action. 
Press Add then Done and that’s it. Whenever 

you create a new document in Photoshop 
from now on, it will automatically 

have your copyright information 
added to it. It’s easy to set up, 

doesn’t take any extra time, and 
it’s “insurance” against forgetting 
to add your copyright. 

 For more ideas on using the Script Events Manager, see  
“Try ’em, You’ll Like ’em” on page 40. 

What’s next?
You’ve seen how to start using the Script Events Manager but 
what happens if the event you’d like to capture isn’t part of the 
event list. As you can see, the event list does have a good share 
of useful events to capture, but there’s definitely more that you 
can do. Glen Stephens wrote a great article for the “Mastering 
Photoshop with Video” column (see Photoshop User, October/
November 2005, p. 72), where he discussed the ability to add an 
event to the Script Events Manager. But why would you want to 
add an event? 
 Let’s say you’re a digital photographer and want to do some-
thing automatically after sharpening a photo with Unsharp 
Mask. For example, I always duplicate the layer before using a 
sharpening filter, then I sharpen the duplicate and add a mask to 
selectively take away any areas that may have been oversharp-
ened. To speed this up, I can capture the Unsharp Mask filter 
event after pressing OK and create the layer mask automatically. 
Just create an action to add a layer mask, set this up in the Script 
Events Manager, and there you go. 
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To illustrate, here’s the Event Codes 
in the JavaScript Reference PDF file that 

comes with Photoshop CS2. If we scroll down to 
the Unsharp Mask event (in Appendix A), you’ll see the 

code to the right. In this case it’s “UnsM” (note that this text is 
case-sensitive). 

 To use this, open the Script Events Manager dialog again. 
Under Photoshop Event, select Add an Event. The dialog that 
appears prompts you for an Event Name and Descriptive Label. 
Under Event Name, type in a descriptive name, such as Unsharp 
Mask Layer Mask, then type in the event code from the Java-
Script reference 
document—in  
our example,  
it’s UnsM—then  
click OK to close 
this dialog. 

Now back in the Script Events Manager, select Action and point 
this setting to an action that adds a layer mask to the current layer. 
Nothing major: a one-step action will do just fine. Now, whenever 
you apply the Unsharp Mask filter to a layer, Photoshop will auto-
matically add a layer mask to that layer for you. If you’re editing a 
lot of digital photos, this can be a huge timesaver. 

Where to go from here?
Obviously, there are many options available to you once you 
start using the Script Events Manager. Hopefully, we’ve whet 

your appetite with the potential of this new feature 
in Photoshop CS2, but the real power comes from 

examining your workflow and thinking  
of repetitive tasks that you can 

replace with the Script  
Events Manager. 

Q&A
Tom Ruark, Senior Computer 
Scientist at Adobe, fields questions 
from Script Events Manager users.

Q. What do I need to know to use  
the Script Events Manager?
A. What you don’t need to know is how to write Scripts. 
 First, you need to know where it is and how to configure 
it. Look under the File>Scripts menu for Script Events 
Manager. Make sure to turn on the Enable Events to Run 
Scripts/Actions checkbox at the top of the dialog. 
 Second, if you find yourself using actions a lot, then you 
can automatically “fire” actions based on what you’re doing 
and when. You can push a lot of decisions into the script 
that’s running after you do something. This is the real power 
of the Script Events Manager.

Q. As a die-hard Photoshop user, what are the “insider” 
(developer) secrets I should know about the Script  
Events Manager?
A. The Script Events Manager is set up so that one event 
fires one script. But the secret event is “event all” (All). This 
will run your script on any event that occurs. It’s a great way 
to get feedback on what’s happening while you execute 
things in Photoshop. 
 Another cool thing about the Script Events Manager 
is that the source code is available. If you’re a script writer 
wondering how to add something that you see the Script 
Events Manager doing, simply grab the code. All the scripts 
found in the File>Scripts can be found here: Applications:
Adobe Photoshop CS2:Presets:Scripts (PC: Program Files\
Adobe Photoshop CS2\Presets\Scripts) and the scripts in 
the other menu are found in the same location under Event 
Scripts Only. Just open the file in a text editor and modify/
copy/paste to suit your needs.

Q. Is there anything the Script Events Manager can’t do?
A. The Script Events Manager runs into the same problem 
that the Actions palette runs into: everything in Photoshop 
isn’t scriptable. Paint strokes, Extract, Vanishing Point, and 
others don’t have scripting hooked up, so you can’t run 
scripts on those events. You can work around this problem 
by manually using scripts inside actions, but it still involves 
some type of manual process.

As Sr. Computer Scientist at Adobe, Tom Ruark is  
responsible for the SDK, plug-in API, and scripting  
API for Photoshop. He’s been at Adobe for eight years  
and now works on Photoshop 100% of the time. Tom  

says he is continually amazed by the popularity of Photoshop and  
the passion of its users. 
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Automatically add certain copyright 
file information (name, year, website) 
to every new document you create 
(or save) in Photoshop (then you 
don’t have to remember to add it).

Convert the Background layer to 
a regular layer (so it’s not locked) 
whenever a new document is 
created. You could also convert the 
Background layer into a Smart Object 
so you can resize it later.

Do you like to have guides that 
show you the center of a document 
in Photoshop? Create an action 
that does this and assign it to the 
Open Document event.  

While we’re on the topic of guides, 
photographers can create an 
action to add guides that conform 
to the “rule of thirds” in photos, 
then you can move, crop, and 
straighten your photos accordingly.

Try ’em, 
You’ll Like ’em
This Script Events idea may be a little over-
whelming at first, so here’s a short list of ideas  
to help you get started:

Create an action that shows all 
(View>Show>All) extra information 
in a Photoshop file (guides, smart 
guides, slices, grids, etc.), then assign 
this to the Open event and you’ll 
always see the extra information 
associated with a Photoshop file.

Let’s say that you have a bunch 
of photos shot under the same 
lighting conditions that you’re color-
correcting with a Curves adjustment 
layer (maybe from a product shoot 
at a studio or even photos taken 
outside that are all similar). Wouldn’t 
it be cool if, when you open the 
photos, you could have the same 
Curves adjustment layer applied to 
them? Then you’d be free to fix other 
problem areas or even change the 
settings in the adjustment layer if 
one specific photo needed it. Well, 
here’s how to do that using the Script 
Events Manager:
 Open one of the photos and create 
an action that adds a Curves adjust-
ment layer, then make your correc-
tions, and press OK to close the dialog. 
Stop recording the action, then set 
up a Script Event for Open Document, 
and specify this action. You could 
even create multiple adjustments for 
other purposes and have your photos 
automatically populated with the 
adjustment layers as you open them. 
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When I duplicate a layer, it’s often 
because I want to do something to 
the top copy, such as sharpening, 
and still have the bottom copy there 
so I can selectively use the two. 
You can create a duplicate layer 
event and assign an action to it that 
automatically creates a layer mask. 
This way, you can sharpen the entire 
photo and then selectively remove 
parts of it using the layer mask. 

Create an action that automatically 
views your images and photos at 
100% (View>Actual Pixels) when  
you open a document.

When you open a document, 
automatically have your images 
and photos viewed at 100%.

Reset to the Default Workspace when-
ever you start Photoshop (Window> 
Workspace>Default Workspace). n

Here’s one from NAPP’s own Dave 
Cross (leave it to him to come up 
with this one). A good prank to play 
on your co-workers or friends is 
to set up an action that flips their 
images upside down (Image>Rotate 
Canvas>Flip Canvas Vertical), then 
add this to the Open Document 
event in the Script Events Manager. 
Now, every time they open a file, it’ll 
be upside down.  

Okay, Dave Cross redeems himself 
with this one: Let’s say you’re a 
photographer and the first thing 
you do when you open a photo 
is duplicate the Background layer 
(Layer>Duplicate Layer) so you 
always have your original intact (a 
very good habit). Why not create 
an action that does this and set the 
Script Events Manager to run this 
action every time you open a file?

Still 
Live In  

Parents’ Basement—

Go Back 4 Spaces


